Advanced CPQ API – GET Prices Returning Completed Status Prematurely

Incident Report for Connectbase

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 23, 2026 - 20:41 EST

Update

We are continuing to investigate this issue.
Posted Feb 23, 2026 - 11:25 EST

Update

We are investigating an issue where the Advanced CPQ v3 GET Prices endpoint may return a Completed status before all external supplier pricing calls have fully finished processing.
This can result in API responses indicating completion while supplier pricing is still reconciling in the background. The TCW UI continues to display the final, accurate pricing state once all supplier calls complete.
Engineering is actively working to resolve the status synchronization issue. Updates will be provided as progress is made.
Posted Feb 23, 2026 - 09:51 EST

Investigating

We are currently investigating this issue.
Posted Feb 23, 2026 - 09:49 EST
This incident affects: API (API - Advanced CPQ).