Elevated Latency Causing Increased Response Times

Incident Report for Connectbase

Resolved

This incident has been resolved.
Posted Sep 23, 2025 - 08:43 EDT

Monitoring

Earlier today, we experienced elevated latency in CPQ, which may have resulted in increased response times and errors for some users. The issue has since stabilized, and CPQ continues to perform reliably. We are actively investigating the root cause to prevent future occurrences. We remain committed to providing a stable and high-performing platform, and we appreciate your continued trust and patience.
Posted Sep 23, 2025 - 08:29 EDT
This incident affected: Quoting (Accounts, Quick Quote).