Reported Issue: Some customers were unable to complete quotes in the CPQ system. Affected quotes showed a "Pricing Failed" status in the UI.
Duration: August 4, 2025 — from 6:15 PM to 10:33 PM UTC (4 hours, 18 minutes)
Cause: The issue was caused by a data error involving duplicate country codes. This conflicted with the quoting system's requirements and led to failures when processing quotes.
Resolution: The duplicate data was corrected, and quoting functionality was fully restored. No further issues have been observed.
Next Steps:
Adding checks to prevent duplicate country codes in the future
Improving data validation during updates
Enhancing monitoring to detect similar issues early
Posted Aug 04, 2025 - 18:34 EDT
Update
We are continuing to monitor for any further issues.
Posted Aug 04, 2025 - 18:33 EDT
Update
We are continuing to monitor for any further issues.
Posted Aug 04, 2025 - 18:32 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 04, 2025 - 18:31 EDT
Investigating
We are currently investigating an issue where some customers are getting Quotes Completing with a Failed Status
Posted Aug 04, 2025 - 17:54 EDT
This incident affected: Quoting (Quick Quote) and Quoting.