Intermittent performance degradation on TCW platform

Incident Report for Connectbase

Resolved

This incident has been resolved.

RCA:

Reported Issue: Users experienced intermittent platform slowness, delays in loading certain features, and temporary session interruptions during normal usage.

Duration: February 10, 3:03 PM UTC – February 10, 3:51 PM UTC (48 minutes)

Cause: A high-volume data retrieval pattern temporarily increased memory utilization within the platform's search and indexing layer. This led to reduced responsiveness and triggered automatic service restarts. While the platform is designed to scale under normal traffic conditions, this specific request pattern consumed more resources than anticipated before the system's workload-balancing mechanisms could compensate.

Solution: The affected services were stabilized and the cluster rebalanced to restore full performance. Preventative measures include enhanced monitoring and logging, adjustments to resource allocation within the virtual machine cluster, implementation of safeguards for large data retrieval patterns, and improvements to batching and paging strategies. These actions strengthen the platform's resilience, scalability, and automated recovery under peak traffic conditions.
Posted Feb 10, 2026 - 10:51 EST

Monitoring

The issue has been resolved and the TCW platform is operating normally. We will continue to monitor for stability.
Posted Feb 10, 2026 - 10:50 EST

Investigating

Intermittent slowness is affecting the TCW platform. Our team is investigating and working to restore full performance. Updates will be provided as available.
Posted Feb 10, 2026 - 10:03 EST
This incident affected: The Connected World.