Quoting issue

Incident Report for Connectbase

Resolved

This incident has been resolved.

RCA:

Reported Issue: Users experienced an inability to access the Quoting functionality within the Accounts module, which disrupted normal business processes.

Duration: August 22, 2025 — 12:24 PM to 12:36 PM UTC (12 minutes)

Cause: A system issue temporarily affected the service that powers quoting functionality.

Solution: Our team quickly restored service and is implementing improvements to prevent similar issues in the future.
Posted Aug 22, 2025 - 15:49 EDT

Update

We are continuing to monitor for any further issues.
Posted Aug 22, 2025 - 15:44 EDT

Monitoring

We are monitoring the issue.
Posted Aug 22, 2025 - 08:33 EDT

Investigating

We are currently investigating an issue related to the Accounts section loading.
Posted Aug 22, 2025 - 08:31 EDT
This incident affected: The Connected World.