Can't Log In / Can't Access

Incident Report for Connectbase

Resolved

Reported Issue:
All Connectbase users were unable to log in, causing a temporary loss of access to the platform.

Duration:
July 16, 2025 — from 2:20 PM to 2:32 PM UTC (12 minutes)

Cause:
The issue was caused by a sudden surge of login requests that overwhelmed the system, resulting in database locking conflicts. These conflicts prevented the system from processing new login attempts until the backlog cleared.

Solution:
The issue self-resolved as the system naturally recovered once the login request volume decreased. Full login access was restored by 2:32 PM UTC without manual intervention.

Next Steps:
To minimize the chance of a recurrence and improve platform reliability, we are actively working on:

Implementing enhanced timeout mechanisms and detailed logging to better manage database load and quickly identify issues (PLAT-3476)

Refining the login process to eliminate unnecessary database updates that cause lock contention, improving performance and stability during peak times (PLAT-3465)
Posted Jul 18, 2025 - 17:14 EDT

Update

We are continuing to monitor for any further issues.
Posted Jul 16, 2025 - 10:33 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 16, 2025 - 10:32 EDT

Investigating

We’re aware of an issue preventing users from logging in or accessing the platform. Our team is actively working to resolve the issue. We’ll provide updates as soon as we have more information. We appreciate your patience.
Posted Jul 16, 2025 - 10:20 EDT
This incident affected: The Connected World.