Reported Issue Some users were unable to log in to the Connectbase platform, resulting in a temporary loss of access to all functionality during the incident window.
Duration Start: July 10, 2024, 5:40 PM UTC End: July 10, 2024, 5:49 PM UTC Total Duration: 9 minutes
Cause The issue was caused by a slowdown in our login system during a spike in user activity. Each login attempt was triggering unnecessary updates in our database, even when no actual changes were needed. This created a traffic jam in the system, which led to delays and prevented some users from logging in.
Our investigation also confirmed a sharp increase in database activity during this time, which contributed to the disruption.
Solution The platform self-recovered without manual intervention as login volume decreased and system resources stabilized.
Next Steps To prevent similar issues going forward:
- We are optimizing the login process to skip unnecessary database updates when user data hasn't changed.
- A code fix is currently in development to ensure updates only occur when needed, which will help reduce contention during high traffic (PLAT-3465).
- We are actively monitoring and analyzing database performance metrics, including thread usage spikes (PDB-1249), to improve platform resilience under load.
Posted Jul 15, 2025 - 16:53 EDT
Update
We are continuing to monitor for any further issues.
Posted Jul 10, 2025 - 14:00 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 10, 2025 - 13:50 EDT
Investigating
We’re aware of an issue preventing users from logging in or accessing the platform. Our team is actively working to resolve the issue. We’ll provide updates as soon as we have more information. We appreciate your patience.