Can't Log In / Can't Access

Incident Report for Connectbase

Resolved

RCA:

Reported Issue: All customers experienced intermittent login challenges and brief platform unavailability on the TCW platform.

Duration: Between September 9 and September 17, 2025.

Cause: A part of our robust authentication system was performing repeated update operations during user login and company-switching workflows. This was amplified when users accessed the platform through multiple browser tabs, resulting in a high volume of simultaneous updates to the same data records. This caused temporary database contention and affected performance.

Solution: Our engineering team acted swiftly to streamline the update logic, removing redundant operations while maintaining the integrity and security of user sessions. Additional safeguards were put in place to ensure updates occur only when necessary, reinforcing platform stability.

Remediation Actions:
We streamlined the update logic to eliminate redundant operations that were not essential to session integrity or user experience.
Additional safeguards were implemented to ensure updates only occur when necessary.
Posted Sep 17, 2025 - 09:42 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 16, 2025 - 07:16 EDT

Investigating

We are currently investigating an increase in system memory which is impacting users logging into The Connected World as well as affecting various API calls on the Advanced CPQv.3 API
Posted Sep 16, 2025 - 06:47 EDT

Monitoring

We are continuing to monitor for any further issues.
Posted Sep 11, 2025 - 09:07 EDT

Investigating

We are investigating an intermittent issue where some users are unable to login to TCW.
Posted Sep 11, 2025 - 09:02 EDT

Update

We are continuing to monitor for any further issues.
Posted Sep 10, 2025 - 12:16 EDT

Monitoring

Our teams have deployed a change that has produced a positive effect. We are seeing successful logins and things appear to be working as expected. That said, we are continuing to monitor the situation and are not prepared to say that this is fully resolved until we have more time to monitor and confirm.
Posted Sep 10, 2025 - 12:15 EDT

Update

The issue has been identified, and a fix is underway. We appreciate your patience as we work to resolve it and will provide an update once the fix is completed.
Posted Sep 10, 2025 - 11:51 EDT

Identified

The issue has been identified, and a fix is underway. We appreciate your patience as we work to resolve it and will provide an update once the fix is completed.
Posted Sep 10, 2025 - 11:50 EDT

Update

We are investigating an intermittent issue where some users are unable to login to TCW.
Posted Sep 10, 2025 - 09:56 EDT

Investigating

We are currently investigating this issue.
Posted Sep 10, 2025 - 09:55 EDT

Monitoring

The platform is currently stable and we're actively monitoring.
Posted Sep 09, 2025 - 16:53 EDT

Investigating

We’re aware of an issue preventing some users from logging in or accessing the platform. Our team is actively working to resolve the issue. We’ll provide updates as soon as we have more information. We appreciate your patience.
Posted Sep 09, 2025 - 16:41 EDT
This incident affected: The Connected World.