Accounts, Quick Quote not loading

Incident Report for Connectbase

Resolved

RCA

Incident Summary
On September 1, some TCW customers experienced difficulties accessing the Accounts page and completing quoting operations.
Duration
The issue lasted approximately 7 minutes, from 12:50 PM UTC to 12:57 PM UTC.
Cause
An unusually high volume of requests temporarily impacted system performance.
Resolution
The service recovered automatically once the request volume subsided. Our team has reviewed the incident and is implementing improvements to further strengthen system reliability.
Posted Sep 01, 2025 - 08:57 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 01, 2025 - 08:50 EDT
This incident affected: Quoting (Accounts).